Slow Response Times
Incident Report for Degreed
Resolved
Our team has resolved our slow response times and Degreed is now operating normally.
Posted Jan 19, 2024 - 07:01 UTC
Identified
Our teams have identified the cause of the slow response times. We're currently working to restore response times back to normal.
Posted Jan 19, 2024 - 06:56 UTC
This incident affected: Degreed US (Degreed Web).